em Geral

Como utilizar o Expo em versões antigas do emulador do iOS

Se você chegou até esta publicação deve estar passando por problemas para utilizar o Expo rodando no iOS 10.2 ou similares correto ?

O fato é que o desenvolvimento Javascript exige que nosso ambiente esteja sempre o mais atualizado possível e isto muitas vezes acaba penalizando quem possui máquina mais antigas ou utilizando Hackintoshs mais antigos.

Bem felizmente isto muitas vezes pode ser contornado, Se você está testando o Expo nas versões mais atualizadas deve ter encontrado erros de compatibilidade de versão e por ai vai.

Como resolver ?

Se você está utilizando assim como eu o emulador do iOS 10.2 você não poderá testar o Expo na versão mais atual. Faça um downgrade em seu app.json localizando a seguinte linha:

"sdkVersion": "36.0.0",

mude a versão da SDK para 33

"sdkVersion": "36.0.0",

Em seu arquivo package.json localize as seguintes linhas:

expo": "~36.0.0","
react": "~16.9.0","
react-dom": "~16.9.0","
react-native": "https://github.com/expo/react-native/archive/sdk-36.0.0.tar.gz"

Mude para a versão do React Native para que fique compatível com:

expo": "~33.0.0","
react": "16.8.3","
react-dom": "~16.9.0","
react-native": "https://github.com/expo/react-native/archive/sdk-33.0.1.tar.gz"",

Feito, agora é só remover o node_modules, rodar o Yarn ou NPM para instalar as dependências e depois iniciar o projeto com o Expo