em Geral

Como resolver Unable to resolve “react-native-gesture-handler”

Caso você já tenha passado por este problema ao desenvolver uma aplicação React Native fique sabendo que o erro é comum e pode ser resolvido com uma certa facilidade.

Este erro pode estar relacionado com a sua versão do Expo como foi no meu caso. A solução mais simples para isto é seguir os comandos abaixo:

rm -rf node_modules

e depois:

npm i -s react-native-gesture-handler
expo install react-native-gesture-handler